gfjardim

[CONTAINER] CrashPlan & CrashPlan-Desktop

Recommended Posts

I was previously having the autostart issue, the following workaround has temporarily resolved it for me:

 

1. SSH into unRAID as root.

2. Determine the container ID

 

docker ps -aqf "name=CrashPlan"

 

3. This will return a string.

3a. Run the following:

 

docker update --restart=always containerID

 

Hopefully this helps someone else who is having this issue. Kudos to the developer of this great docker, hopefully we can find a more permanent solution to this annoying but minor bug.

 

Worked here as a fix, thanks a bunch!

Share this post


Link to post
Share on other sites

My backup has begun to fail (only about half way complete), and I get the following messages in my log:

 

Quote

 

VNCSConnST: Client pixel format depth 24 (32bpp) little-endian rgb888
./run: line 20: 7877 Killed $JAVACOMMON $SRV_JAVA_OPTS -classpath "$TARGETDIR/lib/com.backup42.desktop.jar:$TARGETDIR/lang" com.backup42.service.CPService > /config/log/engine_output.log 2> /config/log/engine_error.log
/opt/startapp.sh: line 22: 7989 Killed ${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > /config/log/desktop_output.log 2> /config/log/desktop_error.log
ERROR: openbox-xdg-autostart requires PyXDG to be installed


./run: line 20: 8058 Killed $JAVACOMMON $SRV_JAVA_OPTS -classpath "$TARGETDIR/lib/com.backup42.desktop.jar:$TARGETDIR/lang" com.backup42.service.CPService > /config/log/engine_output.log 2> /config/log/engine_error.log
/opt/startapp.sh: line 22: 8180 Killed ${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > /config/log/desktop_output.log 2> /config/log/desktop_error.log
ERROR: openbox-xdg-autostart requires PyXDG to be installed


./run: line 20: 8241 Killed $JAVACOMMON $SRV_JAVA_OPTS -classpath "$TARGETDIR/lib/com.backup42.desktop.jar:$TARGETDIR/lang" com.backup42.service.CPService > /config/log/engine_output.log 2> /config/log/engine_error.log
/opt/startapp.sh: line 22: 8361 Killed ${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > /config/log/desktop_output.log 2> /config/log/desktop_error.log
ERROR: openbox-xdg-autostart requires PyXDG to be installed


./run: line 20: 8423 Killed $JAVACOMMON $SRV_JAVA_OPTS -classpath "$TARGETDIR/lib/com.backup42.desktop.jar:$TARGETDIR/lang" com.backup42.service.CPService > /config/log/engine_output.log 2> /config/log/engine_error.log
/opt/startapp.sh: line 22: 8548 Killed ${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > /config/log/desktop_output.log 2> /config/log/desktop_error.log


ERROR: openbox-xdg-autostart requires PyXDG to be installed
./run: line 20: 8607 Killed $JAVACOMMON $SRV_JAVA_OPTS -classpath "$TARGETDIR/lib/com.backup42.desktop.jar:$TARGETDIR/lang" com.backup42.service.CPService > /config/log/engine_output.log 2> /config/log/engine_error.log
/opt/startapp.sh: line 22: 8721 Killed ${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > /config/log/desktop_output.log 2> /config/log/desktop_error.log


ERROR: openbox-xdg-autostart requires PyXDG to be installed
./run: line 20: 8781 Killed $JAVACOMMON $SRV_JAVA_OPTS -classpath "$TARGETDIR/lib/com.backup42.desktop.jar:$TARGETDIR/lang" com.backup42.service.CPService > /config/log/engine_output.log 2> /config/log/engine_error.log
/opt/startapp.sh: line 22: 8906 Killed ${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > /config/log/desktop_output.log 2> /config/log/desktop_error.log
ERROR: openbox-xdg-autostart requires PyXDG to be installed

 

Share this post


Link to post
Share on other sites
On 18-7-2014 at 2:05 AM, ljm42 said:

 

According to the Crashplan help pages:

  http://support.code42.com/CrashPlan/Latest/Troubleshooting/CrashPlan_Runs_Out_Of_Memory_And_Crashes

 

 

 

What I do to try and get around this is create multiple backup sets.  My theory is that if I can keep each backup set to around 1 TB I'll be ok.  It seems to work, I've backed up 3.5 TB so far and haven't had any memory problems.

 

But 30 TB is a different story :) That would probably take a few years to backup.  I'd use Crashplan for your critical data and then find some other kind of local backup for the less critical data.

 

I have a 30 TB unraid that is backupping through crashplan to my backup unraid system.. Crashplan has 16GB and that is more then enough.. The 1GB per TB is made for a typical spread in files... When you are mostly storing movies and series I think the number of files you are backupping is much lower than an average so you can get away with less memory..

 

Share this post


Link to post
Share on other sites

I have allocated 3 GB memory (1 GB is default) and that works fine for me with 12 TB in one backup set. It doesn’t hurt to allocate more memory since CrashPlan only uses what’s needed.

Share this post


Link to post
Share on other sites

UPDATE:  May actually be a RAM issue causing it to crash since my backup was large... Increased to 5GB of ram, and we will see if it works.

 

Need some help, my crashplan keeps crashing while trying to backup.  I lost my cache drive and subsequently was not backing up my appdata folder (shame on me)

 

since then i made a new docker, used community app to redownload CP, and then set it up from scratch again, choosing to restore from a previous PC option to sync the data. 

 

not sure what any of this means, but have been getting this similar error over and over  

 

any help is appreciated. 

 

Think the key is "ERROR: openbox-xdg-autostart requires PyXDG to be installed"

 

 

Xvnc TigerVNC 1.7.0 - built Sep 8 2016 10:39:22
Copyright (C) 1999-2016 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 11400000, The X.Org Foundation

Initializing built-in extension VNC-EXTENSION
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension GLX

Tue Mar 7 15:48:58 2017
vncext: VNC extension running!
vncext: Listening for VNC connections on all interface(s), port 4239
vncext: created VNC server for screen 0
Warning: could not find self.pem

Using local websockify at /opt/novnc/utils/websockify/run
Starting webserver and WebSockets proxy on port 4280
ERROR: openbox-xdg-autostart requires PyXDG to be installed



WebSocket server settings:
- Listen on :4280
- Flash security policy server
- Web server. Web root: /opt/novnc
- No SSL/TLS support (no cert file)
- proxying from :4280 to localhost:4239
Mar 7 15:48:58 unRAID syslog-ng[31]: syslog-ng starting up; version='3.5.6'



Navigate to this URL:

http://unRAID:4280/vnc.html?host=unRAID&port=4280

Press Ctrl-C to exit

 

Edited by bobekdj

Share this post


Link to post
Share on other sites

hi, I've tried to use the search function and it won't pull up any new results for what I'm looking for (older releases). the problem is everytime i need to reboot the unraid server the crashplan engine comes back with an error unable to connect to back up engine, retry and i could click retry for days. finally i have to delete the app and reinstall in order to get it to work, then have to re-adopt my backup and wait for it to sync. 

 

any help would be appreciated. 

 

thanks

Share this post


Link to post
Share on other sites
On 2017-03-07 at 8:53 PM, bobekdj said:

UPDATE:  May actually be a RAM issue causing it to crash since my backup was large... Increased to 5GB of ram, and we will see if it works.

 

Need some help, my crashplan keeps crashing while trying to backup.  I lost my cache drive and subsequently was not backing up my appdata folder (shame on me)

 

since then i made a new docker, used community app to redownload CP, and then set it up from scratch again, choosing to restore from a previous PC option to sync the data. 

 

not sure what any of this means, but have been getting this similar error over and over  

 

any help is appreciated. 

 

Think the key is "ERROR: openbox-xdg-autostart requires PyXDG to be installed"

 

 


Xvnc TigerVNC 1.7.0 - built Sep 8 2016 10:39:22
Copyright (C) 1999-2016 TigerVNC Team and many others (see README.txt)
See http://www.tigervnc.org for information on TigerVNC.
Underlying X server release 11400000, The X.Org Foundation

Initializing built-in extension VNC-EXTENSION
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension GLX

Tue Mar 7 15:48:58 2017
vncext: VNC extension running!
vncext: Listening for VNC connections on all interface(s), port 4239
vncext: created VNC server for screen 0
Warning: could not find self.pem

Using local websockify at /opt/novnc/utils/websockify/run
Starting webserver and WebSockets proxy on port 4280
ERROR: openbox-xdg-autostart requires PyXDG to be installed



WebSocket server settings:
- Listen on :4280
- Flash security policy server
- Web server. Web root: /opt/novnc
- No SSL/TLS support (no cert file)
- proxying from :4280 to localhost:4239
Mar 7 15:48:58 unRAID syslog-ng[31]: syslog-ng starting up; version='3.5.6'



Navigate to this URL:

http://unRAID:4280/vnc.html?host=unRAID&port=4280

Press Ctrl-C to exit

 

 

Don’t think you need to worry about the errors in the log, I see the same but CrashPlan works flawlessly regardless of them ….

 

Share this post


Link to post
Share on other sites
5 hours ago, andr3ws said:

hi, I've tried to use the search function and it won't pull up any new results for what I'm looking for (older releases). the problem is everytime i need to reboot the unraid server the crashplan engine comes back with an error unable to connect to back up engine, retry and i could click retry for days. finally i have to delete the app and reinstall in order to get it to work, then have to re-adopt my backup and wait for it to sync. 

 

any help would be appreciated. 

 

thanks

 

It’s hard to give good suggestions without more details.

  • Do you use the CrashPlan Docker container?
  • Has it been working in the past? When did this problem start to occur?
  • Are you backing up to the CrashPlan cloud or to a local or remote folder?

There are a lot of different log files related to backup, restore, backup service and history. They are located in the log folder. Open the most recent ones and search for Errors to see if you can get some useful information out of that.

CrashPlan also have support pages that can be useful to search trough.

CrashPlan.png

Share this post


Link to post
Share on other sites
7 hours ago, Leifgg said:

 

Don’t think you need to worry about the errors in the log, I see the same but CrashPlan works flawlessly regardless of them ….

 

I Concur 

Share this post


Link to post
Share on other sites

MyCrashPlan has been starting to fail backups. If I watch it in VNC, I see a message box pop up that says:

 

Quote

CrashPlan has been disconnected from the backup engine.

 

I also see this in my log:

 

Quote

./run: line 20: 435 Killed $JAVACOMMON $SRV_JAVA_OPTS -classpath "$TARGETDIR/lib/com.backup42.desktop.jar:$TARGETDIR/lang" com.backup42.service.CPService > /config/log/engine_output.log 2> /config/log/engine_error.log
/opt/startapp.sh: line 22: 550 Killed ${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > /config/log/desktop_output.log 2> /config/log/desktop_error.log


ERROR: openbox-xdg-autostart requires PyXDG to be installed
./run: line 20: 617 Killed $JAVACOMMON $SRV_JAVA_OPTS -classpath "$TARGETDIR/lib/com.backup42.desktop.jar:$TARGETDIR/lang" com.backup42.service.CPService > /config/log/engine_output.log 2> /config/log/engine_error.log
/opt/startapp.sh: line 22: 732 Killed ${JAVACOMMON} ${GUI_JAVA_OPTS} -classpath "./lib/com.backup42.desktop.jar:./lang:./skin" com.backup42.desktop.CPDesktop > /config/log/desktop_output.log 2> /config/log/desktop_error.log


ERROR: openbox-xdg-autostart requires PyXDG to be installed

 

 

 

Does anyone know what's causing this? It looks similar to the problem cyriouslydylan is having.

 

Thank you!

Share this post


Link to post
Share on other sites
On 3/26/2017 at 6:21 AM, ksignorini said:
 

Same here. I was getting the PyXDG error (and it still shows up in my logs), however, after increasing the max memory my backups are finally running again. 

 

Thanks @ksignorini !

Share this post


Link to post
Share on other sites

This was working great for a while, unfortunately, now I just get a 'waiting for connection' when trying to backup to CrashPlan central. I searched this topic but didn't find anything too helpful. Any suggestions?

 

Thanks!

 

Share this post


Link to post
Share on other sites

I am having several "issues" with the docker.

 

Firstly, I would like to clarify whether crashplan is supposed to run only on a single core? I see it pinning a single core to whatever I will allow it and moving on to another etc. Is there anyway to allow for multicore process.

 

Secondly, once in a while I get an issue with UnRaid becoming unresponsive due to large iowait values. I have narrowed the issue down to crashplan docker, however I have no idea where the crazy io requests are coming from. THe problem is usually solved by restarting the docker. I attach the docker logs. 

 

Would be great if someone could chime in on those issues... 

log (2).zip

Share this post


Link to post
Share on other sites
18 hours ago, DoeBoye said:

 

I'm assuming it saves it to the config and doesn't need to be re-done on reboot, right?

Yepp, it will survive a reboot. The change you made is stored in the file run.conf located here: appdata\Chrasplan\bin

  • Upvote 1

Share this post


Link to post
Share on other sites
1 hour ago, MrChunky said:

I am having several "issues" with the docker.

 

Firstly, I would like to clarify whether crashplan is supposed to run only on a single core? I see it pinning a single core to whatever I will allow it and moving on to another etc. Is there anyway to allow for multicore process.

 

Secondly, once in a while I get an issue with UnRaid becoming unresponsive due to large iowait values. I have narrowed the issue down to crashplan docker, however I have no idea where the crazy io requests are coming from. THe problem is usually solved by restarting the docker. I attach the docker logs. 

 

Would be great if someone could chime in on those issues... 

log (2).zip

Firstly, I have been running CrashPlan for a bit more than two years but I am unfortunately not able to give much help but here are my thoughts…

The CrashPlan Java app is developed and maintained by CrashPlan and gfjardim (the maintainer of this Docker container) downloads the app and make the adaptations needed for this Docker container. I would assume that any adaptation for multicore processes I best done by CrashPlan.

Regarding the inotify problems I can only say that I haven’t seen them myself and I have around 450.000 files (12 TBytes). From what I can see from your logs there are a lot related to Plex and I don’t have any of these errors in my logs (I use Plex as well).

Here is a link that talks about inotify:

https://support.code42.com/CrashPlan/4/Troubleshooting/Linux_Real-Time_File_Watching_Errors

The only thoughts I have about this is if it could be related to permissions (access rights) to the files on the appdata share?

And BTW, some of the log files you provided contains (sensitive) personal information so you might prefer to edit your post...

Share this post


Link to post
Share on other sites
38 minutes ago, Leifgg said:

 

The best way to increase the inotify max_user_watches value on unRAID is by using the Tips and Tweaks plugin.  As a start, you can double the default number.

 

I'd also recommend installing the Fix Common Problems plugin, as it could have alerted you to this inotify watch problem. There may be other issues it can help with as well. 

Share this post


Link to post
Share on other sites
3 hours ago, Leifgg said:

Firstly, I have been running CrashPlan for a bit more than two years but I am unfortunately not able to give much help but here are my thoughts…

 

The CrashPlan Java app is developed and maintained by CrashPlan and gfjardim (the maintainer of this Docker container) downloads the app and make the adaptations needed for this Docker container. I would assume that any adaptation for multicore processes I best done by CrashPlan.

 

Regarding the inotify problems I can only say that I haven’t seen them myself and I have around 450.000 files (12 TBytes). From what I can see from your logs there are a lot related to Plex and I don’t have any of these errors in my logs (I use Plex as well).

 

Here is a link that talks about inotify:

 

https://support.code42.com/CrashPlan/4/Troubleshooting/Linux_Real-Time_File_Watching_Errors

 

The only thoughts I have about this is if it could be related to permissions (access rights) to the files on the appdata share?

 

And BTW, some of the log files you provided contains (sensitive) personal information so you might prefer to edit your post...

 

 

Forgive me if I am talking nonsense, as I am not particularly well versed in this.

 

In my post I mentioned that I see high iowait values, which I assume are related to large number of requests to a storage drive? How does inotify relate to this issue?

 

I have already doubled the inotify resource through the Tips and Tricks plugin from the original  value (something around 500000).

Share this post


Link to post
Share on other sites
39 minutes ago, MrChunky said:

In my post I mentioned that I see high iowait values, which I assume are related to large number of requests to a storage drive? How does inotify relate to this issue?

 

For me anyway, I don't know how you are measuring iowait or how you determined Crashplan was the problem.

 

But... the service.log.0 you uploaded contains many lines that look like this:

[04.12.17 10:46:41.721 WARN  Thread-127   ode42.jna.inotify.InotifyManager] Unable to add watch for path /mnt/user/...

according to the link above, that means need to increase your inotify watch value.

 

Whether it will fix the problem you are trying to solve, I don't know :) but it will fix *a* problem.

 

I suggested the Fix Common Problems plugin because it reduces a bunch of complex troubleshooting steps down to the click of a button.  I can't guarantee it will solve this problem, but it will almost certainly help.

 

If you are still having problems after that you might need to contact Crashplan. If you find the solution, please let us know.

Share this post


Link to post
Share on other sites
On 4/12/2017 at 10:48 PM, ljm42 said:

 

For me anyway, I don't know how you are measuring iowait or how you determined Crashplan was the problem.

 

But... the service.log.0 you uploaded contains many lines that look like this:


[04.12.17 10:46:41.721 WARN  Thread-127   ode42.jna.inotify.InotifyManager] Unable to add watch for path /mnt/user/...

according to the link above, that means need to increase your inotify watch value.

 

Whether it will fix the problem you are trying to solve, I don't know :) but it will fix *a* problem.

 

I suggested the Fix Common Problems plugin because it reduces a bunch of complex troubleshooting steps down to the click of a button.  I can't guarantee it will solve this problem, but it will almost certainly help.

 

If you are still having problems after that you might need to contact Crashplan. If you find the solution, please let us know.

I have increased the inotify value yet again. I haven't had the locking up behavior since. Not sure if it solved the problem, but I haven't seen it for a while. Thanks for the suggestions.

Share this post


Link to post
Share on other sites
9 hours ago, MrChunky said:

I have increased the inotify value yet again. I haven't had the locking up behavior since. Not sure if it solved the problem, but I haven't seen it for a while. Thanks for the suggestions.

That is great news!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.