jumperalex

CPU freq not stepping down

Recommended Posts

not working for me either

 

root@Tower:~# cat /proc/cpuinfo |egrep -i mhz
cpu MHz         : 2833.250
cpu MHz         : 2833.250
cpu MHz         : 2833.250
cpu MHz         : 2833.250
cpu MHz         : 2833.250
cpu MHz         : 2833.250
cpu MHz         : 2833.250
cpu MHz         : 2833.250

Share this post


Link to post
Share on other sites

My server has an i7-4790 (Hashwell Refreh) With Unraid 6.2 its idle.

cat /proc/cpuinfo |egrep -i mhz
cpu MHz		: 1999.968
cpu MHz		: 1770.750
cpu MHz		: 3400.171
cpu MHz		: 1599.890
cpu MHz		: 1787.062
cpu MHz		: 2046.796
cpu MHz		: 1951.734
cpu MHz		: 902.390

This is with 2 VM's running continue..

 

But with the I5-4460 it didn't idle...

Share this post


Link to post
Share on other sites

My i3-4160 is stepping down perfectly in unraid 6.2, both on the Dashboard and with the "cat /proc/cpuinfo |egrep -i mhz" command.

 

I clearly see all four available cores idling at around 0% on the Dashboard screen, even while it is open and cpuinfo reporting 800MHz speeds with the occasional core going up to around 1100MHz if something polls.

Share this post


Link to post
Share on other sites

I researched this issue because the Plugin "Fix Common Problems" listed my CPU possibly will not throttle down frequency at idle. I made the change to the syslinux.cfg file, saved, verified the change and rebooted but my i7-860 Lynnfield is still running at full 2.8 GHz when at idle. I am running a newly built 17 drive Unraid 6.2.4. Reading the replies the solution will not come easy due to the many different CPUs. I will keep my fingers crossed and thank you!

 

cat /proc/cpuinfo |egrep -i mhz

cpu MHz        : 2797.996

cpu MHz        : 2797.996

cpu MHz        : 2797.996

cpu MHz        : 2797.996

cpu MHz        : 2797.996

cpu MHz        : 2797.996

cpu MHz        : 2797.996

cpu MHz        : 2797.996

 

Snap_2016-12-08_at_15_14_46.jpg.10b56a77a8a75e1721603b95f4cf98af.jpg

Share this post


Link to post
Share on other sites

I researched this issue because the Plugin "Fix Common Problems" listed my CPU possibly will not throttle down frequency at idle.

Just as a background that might help, that test was suggested by RobJ, and is simply the output of the command
cpufreq-info -d

If there is no output from that command, then FCP flags it as a possibility that the CPU will never step down.

Share this post


Link to post
Share on other sites

Thank for your reply Squid. The command "cpufreq-info -d" did not return an output.

Snap_2016-12-08_at_22_36_00.jpg.d454be6baec4783dd5ebdcd158e3bdae.jpg

Share this post


Link to post
Share on other sites

Yeah i agree this is still an issue on 6.2.4

 

without pstates off i get 4ghz min but with pstates turned off i get

cat /proc/cpuinfo |egrep -i mhz
cpu MHz         : 4001.000
cpu MHz         : 800.000
cpu MHz         : 1300.000
cpu MHz         : 1000.000
cpu MHz         : 4001.000
cpu MHz         : 800.000
cpu MHz         : 1000.000
cpu MHz         : 1000.000

cat /proc/cpuinfo |egrep -i mhz
cpu MHz         : 2400.000
cpu MHz         : 800.000
cpu MHz         : 1000.000
cpu MHz         : 1000.000
cpu MHz         : 4001.000
cpu MHz         : 800.000
cpu MHz         : 800.000
cpu MHz         : 1000.000

 

root@CY-HV:~# grep -m 1 'model name' < /proc/cpuinfo

model name      : Intel® Core i7-4790K CPU @ 4.00GHz

 

proper scaling, the problem for me is without pstates on i don't get my custom overclock of 4.7ghz

 

any suggestions?

 

EDIT: this is my freqs with unraid doing the same things as it was when pstates was disabled, but running way higher.

cat /proc/cpuinfo |egrep -i mhz
cpu MHz         : 4699.843
cpu MHz         : 4697.968
cpu MHz         : 4699.843
cpu MHz         : 4700.156
cpu MHz         : 4699.843
cpu MHz         : 4704.375
cpu MHz         : 4700.000
cpu MHz         : 4700.000

Share this post


Link to post
Share on other sites

Up until a day ago, I don't think I had a problem with the CPU frequency stepping down.  I am somewhat new to all of this, but my system was running what I'll call "normally".  Last night, the power went out for an hour or so, and upon restarting my server, the fan(s) seems to run at high/full speed all of the time (which is much noisier as well!).  Prior to the power outage, the fan(s) would only run full speed for about 10 seconds or so after a boot. 

 

The fix common problems plugin now indicates "Your CPU is running constantly at 100% and will not throttle down when it's idle".  If memory serves, that message was something like "Your CPU may not throttle down ...."  prior to the power outage.  So, I've been trying to find a CPU scaling driver - and that has led me to this thread.

 

I've checked my server machine BIOS and all seems to be "normal".   I don't see a SpeedStep setting, but I assume that "Deep C-State" is the same (at least based on the setting description in the BIOS); therefore, I've left that enabled.

 

My command line results are as follows:

grep -m 1 'model name' < /proc/cpuinfo
     Intel(R) Xeon(TM) CPU 3.20GHz        ## Intel Server Board S5000PSL motherboard ##
     

awk '/^cpu MHz/ {print $4*1" MHz"}' /proc/cpuinfo
     3191.87 MHz
     3191.87 MHz
     3191.87 MHz
     3191.87 MHz
     3191.87 MHz
     3191.87 MHz
     3191.87 MHz
     3191.87 MHz
     
     
cat /proc/cpuinfo |egrep -i mhz
     cpu MHz         : 3191.873
     cpu MHz         : 3191.873
     cpu MHz         : 3191.873
     cpu MHz         : 3191.873
     cpu MHz         : 3191.873
     cpu MHz         : 3191.873
     cpu MHz         : 3191.873
     cpu MHz         : 3191.873

 

The UnRAID GUI shows:

 

iggZMoZm.png

 

 

Is my next step to edit syslinux.cfg and add the pstate=disabled line?  If so, where might I find the syslinux.cfg file.  So far, I've been unable to locate it.

 

 

**Edit 1:  Reduced size of the embedded image

**Edit 2:  I have located the file and will see what the edit does ... 

 

Edited by ATEglauer

Share this post


Link to post
Share on other sites

r u guys using 6.4? I also thought it wont throttle down, but it was. On 6.4 atleast. If nothing is done my u3 now only takes 65 watt incl. USP

 

Edit: found my thread:

 

Whats the reason some ppl still use old versions of unraid? 

Edited by nuhll

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2017 Lime Technology, Inc. unRAID® is a registered trademark of Lime Technology, Inc.