Squid

[Plug-In] Community Applications

2117 posts in this topic Last Reply

Recommended Posts

Hold on, found the issue:

https://github.com/sparklyballs/beta-repo/tree/master that's what is being sent in the webhook

https://github.com/sparklyballs/beta-repo/tree/master/Sparkly-Beta is what is in Squids list, whch will produce different hash values, it should hopefully be fixed now.

 

i'll push a change in my main repo see if that's set correctly too...

 

i'll move daapd-server from beta to main...

 

kill 2 birds with one stone and test both.

Share this post


Link to post

Hello, not sure it's the right place but can you add my repository to the list? (this one https://github.com/sdesbure/docker-containers)

thanks!

Just woke up.  Gimme an hour or two.

Added.

 

You should add the <Date> entry to the template so that it shows up in the new / updated list.

 

If you're running CA using Kode's feed, then the app should be available within two hours.  If you're not using Kode's feed with CA, the App is available immediately.  (Working on an update to alleviate this to a certain extent)

 

Hi and thanks!

I'll test in the next 2 hours!

Share this post


Link to post

Hi and thanks!

I'll test in the next 2 hours!

It's already on there

Share this post


Link to post

Just to clarify, I wanted to point out that Kode's feed is still what I would classify as being "beta" feature of CA.  As you could tell from the previous bunch of posts, there still are a couple of issues to work out.  Nothing harmful however will happen should you enable Kode's feed within CA.  The worst thing will be that a few applications may not show up in the list (as of this writing, there are a couple).  Should you choose not to help us debug this new feature, then do not enable Kode's feed within CA's settings.

 

As an aside, the next update for CA (probably tomorrow) will support private repositories in conjunction with the app feed, and will also lower the memory footprint of this plugin by ~2 Meg (if using the app feed) and by 1 Meg if you're not.

 

Once everything is rock solid, then the application feed will become the default method of using CA (with an automatic fallback to the template mode if the app feed for whatever reason is unavailable)

Share this post


Link to post

Updated to 2015.07.16

 

- Private repositories will now work with Kode's application feed

- Reduced the memory footprint of the plugin by ~2 Meg if using Kode's feed and ~1 Meg if not using it

- If Kode's feed is for whatever reason unavailable, the system will revert back to the normal template downloading system

- Application feed changed slightly between yesterday's update (2015.07.15) and this one with the net result that applications were not installing properly - fixed.

- Added baseOS to the description in Icon Mode.  Note that this information is ONLY available in the application feed mode.

 

- Update Applications works a little bit differently is you're using the application feed:

 

 

Hitting Update Applications while using the application feed will temporarily revert the system to the template downloading method.  This is useful for when you know that an update or a new application or new repository is available, but the application feed hasn't picked it up yet (and you just can't wait for its next hourly update). 

 

Note that if automatic updates are turned on in conjunction with the appfeed, then when you leave the docker tab and then re-enter it any changes which Update Applications found will be lost either until the next cycle of Kode's feed (hourly), or you hit Update Applications again.

 

Also note that as of this writing, there is an issue with the application feed itself where it is not completely populating gfjardim's repository (it's missing gfjardim and needo)  This issue does NOT affect CA in the template mode.  I have no doubt that Kode will address this shortly.

Share this post


Link to post

Until I came here and saw a update - I was in the process of removing plex and going with another and upon clicking the add button.....

 

Warning: DOMDocument::load(): Document is empty in /var/lib/docker/unraid/templates-community-apps/plex.xml, line: 1 in /usr/local/emhttp/plugins/dynamix.docker.manager/createDocker.php on line 377 Warning: DOMDocument::load(): Start tag expected, '<' not found in /var/lib/docker/unraid/templates-community-apps/plex.xml, line: 1 in /usr/local/emhttp/plugins/dynamix.docker.manager/createDocker.php on line 377
Template: 	

 

After updating - it started working fine - hopefully ppls notice there is a update that is now required for it to work correctly

 

Myk

 

Share this post


Link to post

All the application should be back in now, there was a typo, sorry about that.

Share this post


Link to post

Until I came here and saw a update - I was in the process of removing plex and going with another and upon clicking the add button.....

 

Warning: DOMDocument::load(): Document is empty in /var/lib/docker/unraid/templates-community-apps/plex.xml, line: 1 in /usr/local/emhttp/plugins/dynamix.docker.manager/createDocker.php on line 377 Warning: DOMDocument::load(): Start tag expected, '<' not found in /var/lib/docker/unraid/templates-community-apps/plex.xml, line: 1 in /usr/local/emhttp/plugins/dynamix.docker.manager/createDocker.php on line 377
Template: 	

 

After updating - it started working fine - hopefully ppls notice there is a update that is now required for it to work correctly

 

Myk

There was a slight change in Kode's application feed which caused that.  The system was working correctly with the feed as it was on 7/15.  Sometime on 7/16 the feed changed (The notice that the feed was changing probably got lost in a PM along the line)

 

Since you were running in the appFeed mode, you could have reverted back to the old template mode and it would have worked correctly.  (Or, with the update 7/16, hit Update Applications, and the error would have fixed itself)

Share this post


Link to post

Until I came here and saw a update - I was in the process of removing plex and going with another and upon clicking the add button.....

 

Warning: DOMDocument::load(): Document is empty in /var/lib/docker/unraid/templates-community-apps/plex.xml, line: 1 in /usr/local/emhttp/plugins/dynamix.docker.manager/createDocker.php on line 377 Warning: DOMDocument::load(): Start tag expected, '<' not found in /var/lib/docker/unraid/templates-community-apps/plex.xml, line: 1 in /usr/local/emhttp/plugins/dynamix.docker.manager/createDocker.php on line 377
Template: 	

 

After updating - it started working fine - hopefully ppls notice there is a update that is now required for it to work correctly

 

Myk

There was a slight change in Kode's application feed which caused that.  The system was working correctly with the feed as it was on 7/15.  Sometime on 7/16 the feed changed (The notice that the feed was changing probably got lost in a PM along the line)

 

Since you were running in the appFeed mode, you could have reverted back to the old template mode and it would have worked correctly.  (Or, with the update 7/16, hit Update Applications, and the error would have fixed itself)

 

Thanks for this! I didn't see the error but when I went to add an application the add container page would be empty instead of prefilled. Clicking the "Update Applications" on the Docker tab for CA worked and now I can add applications again.

Share this post


Link to post

Until I came here and saw a update - I was in the process of removing plex and going with another and upon clicking the add button.....

 

Warning: DOMDocument::load(): Document is empty in /var/lib/docker/unraid/templates-community-apps/plex.xml, line: 1 in /usr/local/emhttp/plugins/dynamix.docker.manager/createDocker.php on line 377 Warning: DOMDocument::load(): Start tag expected, '<' not found in /var/lib/docker/unraid/templates-community-apps/plex.xml, line: 1 in /usr/local/emhttp/plugins/dynamix.docker.manager/createDocker.php on line 377
Template: 	

 

After updating - it started working fine - hopefully ppls notice there is a update that is now required for it to work correctly

 

Myk

There was a slight change in Kode's application feed which caused that.  The system was working correctly with the feed as it was on 7/15.  Sometime on 7/16 the feed changed (The notice that the feed was changing probably got lost in a PM along the line)

 

Since you were running in the appFeed mode, you could have reverted back to the old template mode and it would have worked correctly.  (Or, with the update 7/16, hit Update Applications, and the error would have fixed itself)

 

Thanks for this! I didn't see the error but when I went to add an application the add container page would be empty instead of prefilled. Clicking the "Update Applications" on the Docker tab for CA worked and now I can add applications again.

Just so I can understand what went wrong here, are you using the app feed with CA?

Share this post


Link to post

If you have problems with CA and are trying out the app feed mode with it, can you post the contents of this website as soon as possible (with whatever application you were trying to add):  http://tools.linuxserver.io/unraid-docker-templates.json

 

That way both Kode (responsible for that feed), and myself (responsible for scraping the information from it) can figure out what's going wrong.  (The feed is >20000 characters, so you won't be able to merely paste the contents.  You'll have to save it to a file and zip it.)

 

CA with app feed disabled should still be 100% rock solid.

Share this post


Link to post

Updated to 2015.07.18

 

- Some coding efficiency improvements

- Revamp of the description section (paving the way for future improvements)

- Support for a Project Home page link

 

Project Home page link (if implemented by the authors / maintainers - see here: http://lime-technology.com/forum/index.php?topic=40299.msg394762#msg394762) will take you to the Project's home page (eg: plex's home page or couch potato's home page). 

 

The link will show up either in the description pop up or in the changelog pop up.

 

 

Also updated the OP with a poll on table mode (should I continue having it)

Share this post


Link to post

6.1 rc-1 moved around (and renamed) some files.  Updated the plugin to 2015.07.19.  This update is required if you run 6.1 rc-1.  The plugin has logic to determine if you are running 6.01 or 6.1 and will adjust itself accordingly.

Share this post


Link to post

Updated to 2015.07.18

 

- Some coding efficiency improvements

- Revamp of the description section (paving the way for future improvements)

- Support for a Project Home page link

 

Project Home page link (if implemented by the authors / maintainers - see here: http://lime-technology.com/forum/index.php?topic=40299.msg394762#msg394762) will take you to the Project's home page (eg: plex's home page or couch potato's home page). 

 

The link will show up either in the description pop up or in the changelog pop up.

 

 

Also updated the OP with a poll on table mode (should I continue having it)

 

i hate icon mode... lol.

Share this post


Link to post

I'm not fond of icon mode myself, like the table mode for quick browsing and sorting.

 

Wouldn't have put it quite as strongly as Sparklyballs.

Share this post


Link to post

Updated to 2015.07.20

 

Primarily a bug fix release.  Most notably, under certain conditions when adding an application a blank template could appear should now be fixed.

 

Few notes:  Under the constant cajoling / threats from sparklyballs, table mode is going to receive the same treatment as icon mode here on in.  To bring it now up to date with icon mode, clicking the application name will now display the pop up with expanded details about the app.  Coding is now almost unified between tables and icons, so it will be far easier to keep them both in sync with each other.  Hovering over the icon in icon mode now displays the description of the app.  However, not all authors properly implemented the "Overview" tag in their templates, so some applications are displaying far more information than they need to.

 

Kode's appfeed looks like the majority of bugs have been worked out, so in a week or two I will make it the default mode of operation for this plugin (if nothing else pops up in either CA or the feed).  Basically waiting for sparkly to add another template to his repository.

 

Still to come -> a unification of the UI between table mode and icon mode.  Have to think about this for a while.  Options in icon mode for when fewer columns are used to display greater information on the screen.  (Have to really sit down and learn CSS for this)

 

Hopefully the last update for a bit.  Now on vacation, and desperately need to have a few pints.

 

 

 

 

 

Share this post


Link to post

how am i suddenly the villain ?

You're convenient

Share this post


Link to post

Hovering over the icon in icon mode now displays the description of the app.  However, not all authors properly implemented the "Overview" tag in their templates, so some applications are displaying far more information than they need to.

 

Why don't you do something like

substr( $overview, 0, 200 );

And let authors know there is a limit of 200 chars (or whatever you decide), anything over that will be strpped out, might make them take more care of their overview.

Share this post


Link to post

Hovering over the icon in icon mode now displays the description of the app.  However, not all authors properly implemented the "Overview" tag in their templates, so some applications are displaying far more information than they need to.

 

Why don't you do something like

substr( $overview, 0, 200 );

And let authors know there is a limit of 200 chars (or whatever you decide), anything over that will be strpped out, might make them take more care of their overview.

Was thinking about the same thing, but in conjunction with this:

Options in icon mode for when fewer columns are used to display greater information on the screen.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2018 Lime Technology, Inc.
unRAID® is a registered trademark of Lime Technology, Inc.