linuxserver.io

[Support] Linuxserver.io - Apache

295 posts in this topic Last Reply

Recommended Posts

Don't really know for sure but I think it is maintained - reboot and find out I guess.  Also if you install it to the container itself then if you delete the container it would be gone and you would have to reinstall again.  If you install it to appdata then it would survive deleting the container.  If you have to symlink to achieve the appdata install then you would have to redo that if you delete the container.

Share this post


Link to post

How would you install to appdata and symlink?  Would you have to link the appdata folder to /usr/bin/python?  What about any libraries that get installed - will they be found?

 

 

Share this post


Link to post

Don't have any idea - sorry.  Just suggesting.  Was hoping you would know what the python install does.  With SageTV container it is already defined with sym links for the SageTV and java directories to go to appdata by stuckless.  Now if all of python including it's libraries get installed to /usr/bin/python then that is all you would need to do.  However what you might consider is to setup up a bash script to do the install and putting the script in an appdata directory that is mapped for the container.  Then any time you setup the container from scratch you just "docker exec -it <container> /bin/bash" and navigate to the script and execute it.

Share this post


Link to post

Recently after an upgrade all I get is a window that says "Exectuion Error, server error"  There are no log files, nothing.  It used to work for me.

 

I just updated again, same issue, removed the docker and image and reinstalled, same issue.

 

any ideas on how to debug what is going on?

 

thanks,

david

 

EDIT: I figure it out.  The new version of unraid uses 443 so I had to change that to a different port.

Edited by lovingHDTV

Share this post


Link to post

Is this docker ever going to be updated? its based on 14.04LTS (now 1 year "obsolete") and is running PHP 5.5. Most apps need at least 5.6 to run, and preferably 7.x. I've tried to manually update it (knowing it would be lost on an update) but it just ends up returning server 500 errors when I try.

Share this post


Link to post
On 01/12/2017 at 5:55 PM, chaosratt said:

Is this docker ever going to be updated? its based on 14.04LTS (now 1 year "obsolete") and is running PHP 5.5. Most apps need at least 5.6 to run, and preferably 7.x. I've tried to manually update it (knowing it would be lost on an update) but it just ends up returning server 500 errors when I try.

 

Don't think we have any plans, we've concentrated our efforts on nginx and letsencrypt

Share this post


Link to post

may just as note for those using ssl and want an automated update via certbot inside apache

 

after installing certbot and functional ssl i made myself this user script (CA User scripts)

 

#!/bin/bash

docker exec -t apache bash ./config/certbot/certbot-auto -n --config /config/certbot/cli.ini certonly

echo Certs renewed

docker cp -L apache:/etc/letsencrypt/live/first.mydomain.com/cert.pem /mnt/user/appdata/apache/keys

docker cp -L apache:/etc/letsencrypt/live/first.mydomain.com/chain.pem /mnt/user/appdata/apache/keys

docker cp -L apache:/etc/letsencrypt/live/first.mydomain.com/fullchain.pem /mnt/user/appdata/apache/keys

docker cp -L apache:/etc/letsencrypt/live/first.mydomain.com/privkey.pem /mnt/user/appdata/apache/keys

echo certs copied

 

my cli.ini looks like this

 

email = mail@mydomain.com
authenticator = apache
agree-tos = True
renew-by-default = True
domains = first.mydomain.com,second.mydomain.com

 

as this apache is updating once a week certbot needs to get renewed always, so i let this script run 2 days afterwards (here on 5th and 6th every month),

like this on 5th it wont update but reinstall all needed stuff, on 6th it will renew the certs then, if there wouldnt be any docker updates then theres no need for 2 runs.

 

just in case somebody has usage herefore.

 

letsencrypt aint a choice for me yet cause missing some webdav functionality, thats why i stay on apache still ;) and was looking for automated ssl updates.

Share this post


Link to post

Just upgraded to 6.4 and my Apache server stopped and won't allow me to start it.  I did have my unRAID go script set to charge emhttp to port 82 (Apache on 80) and had to stop that and change unRaid via Settings/Identification as we are told to do. Any idea why the Apache docker stopped now - I have all my other Docker WebUIS proxied by Apache so I need Apache working!!

Share this post


Link to post
Just upgraded to 6.4 and my Apache server stopped and won't allow me to start it.  I did have my unRAID go script set to charge emhttp to port 82 (Apache on 80) and had to stop that and change unRaid via Settings/Identification as we are told to do. Any idea why the Apache docker stopped now - I have all my other Docker WebUIS proxied by Apache so I need Apache working!!
Docker run command? And any errors/logs

Sent from my LG-H815 using Tapatalk

Share this post


Link to post

Thanks, I'm ashamed to say I have no idea where I find my Docker "run command". Apache log was too big to open so zapped and re-started Apache and no log created. Doesnt get that far! If I start the Docker from the button all I get is a requestor with 

Execution error

Server error

 

I do see it says Bridge Host None Br0 in Network type and Bridge is selected. Never noticed that before. Thought options were Bridge and Host?

 

Edited by methanoid

Share this post


Link to post
Thanks, I'm ashamed to say I have no idea where I find my Docker "run command". Apache log was too big to open so zapped and re-started Apache and no log created. Doesnt get that far! If I start the Docker from the button all I get is a requestor with 

Execution error

Server error

 

I do see it says Bridge Host None Br0 in Network type and Bridge is selected. Never noticed that before. Thought options were Bridge and Host?

 
My sig shows how to get docker run command.

Yeah, new option for interface....

Sent from my LG-H815 using Tapatalk

Share this post


Link to post

Thanks, had switched off sigs a while back (ooops!). I assume from the text below its related to unRAID using HTTPS for web now? Is there anyway to fix that or should I just make Apache use 444 instead (dont think I really use https)...

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="Apache" --net="bridge" -e TZ="Europe/London" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 80:80/tcp -p 443:443/tcp -v "/mnt/user/appdata/apache":"/config":rw linuxserver/apache

5d6834ddb57b6a9abfc2f1b8d9f8c0c8879a4b5169c1588b19a54629a3186372
/usr/bin/docker: Error response from daemon: driver failed programming external connectivity on endpoint Apache (71ced0e2dde455b75d4d3082c104b503e4ae8a7bf6c6bb5b9fd58473c1c2294f): Error starting userland proxy: listen tcp 0.0.0.0:443: bind: address already in use.

The command failed.

Share this post


Link to post

Just change Apache to use 444 and change the forwarding in your router

 

OR

 

Turn off/reallocate  443/SSL in Unraid

  • Like 1

Share this post


Link to post

This docker plugin has started failing for me after my last restart. First question is if anyone knows how to fix it, second is whether there's a known replacement. The docker pages shows it as deprecated/no longer supported: https://hub.docker.com/r/linuxserver/apache/

 

Reading package lists...
Setting up php5-fpm (5.5.9+dfsg-1ubuntu4.25) ...

Configuration file '/etc/php5/fpm/pool.d/www.conf'
==> Modified (by you or by a script) since installation.
==> Package distributor has shipped an updated version.

What would you like to do about it ? Your options are:
Y or I : install the package maintainer's version

N or O : keep your currently-installed version

D : show the differences between the versions
Z : start a shell to examine the situation
The default action is to keep your current version.

*** www.conf (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing package php5-fpm (--configure):

EOF on stdin at conffile prompt
Errors were encountered while processing:


E: Sub-process /usr/bin/dpkg returned an error code (1)

*** /etc/my_init.d/20_apt_update.sh failed with status 100

 

Share this post


Link to post

Deprecated??! WTF!?     And if its not been updated why has it suddenly stopped working?

Share this post


Link to post

Hello

 

I have a problem when i boot the docker image , after 3mn he reboot with error code :


 

Setting up libapache2-mod-proxy-html (1:2.4.7-1ubuntu4.20) ...
Processing triggers for libapache2-mod-php5 (5.5.9+dfsg-1ubuntu4.25) ...
Errors were encountered while processing:
 php5-fpm
E: Sub-process /usr/bin/dpkg returned an error code (1)
*** /etc/my_init.d/20_apt_update.sh failed with status 100

*** Killing all processes...

 

and reboot all the time , i dont have problem before that ...

 

Help please

Share this post


Link to post

I am receiving the same error since the last reboot:

 

 

 

*** Running /etc/my_init.d/00_regen_ssh_host_keys.sh...
*** Running /etc/my_init.d/04_set_timezone.sh...
*** Running /etc/my_init.d/10_add_user_abc.sh...

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

*** Running /etc/my_init.d/20_apt_update.sh...
finding fastest mirror
Getting list of mirrors...done.
Testing latency to mirror(s)
Getting list of launchpad URLs...done.
Looking up 3 status(es)
1. ny-mirrors.evowise.com
Latency: 6.76 ms
Org: Evowise.com
Status: Up to date
Speed: 10 Gbps
2. mirrors.accretive-networks.net (current)
Latency: 6.92 ms
Org: Accretive Networks
Status: Up to date
Speed: 1 Gbps
3. la-mirrors.evowise.com
Latency: 7.05 ms
Org: Evowise.com
Status: Up to date
Speed: 10 Gbps
New config file saved to /defaults/sources.list
We are now refreshing packages from apt repositories, this *may* take a while
1. ny-mirrors.evowise.com
Latency: 6.76 ms
Org: Evowise.com
Status: Up to date
Speed: 10 Gbps
2. mirrors.accretive-networks.net (current)
Latency: 6.92 ms
Org: Accretive Networks
Status: Up to date
Speed: 1 Gbps
3. la-mirrors.evowise.com
Latency: 7.05 ms
Org: Evowise.com
Status: Up to date
Speed: 10 Gbps
New config file saved to /defaults/sources.list
We are now refreshing packages from apt repositories, this *may* take a while
Ign http://ny-mirrors.evowise.com trusty InRelease
Get:1 http://ny-mirrors.evowise.com trusty-updates InRelease [65.9 kB]
Get:2 http://ny-mirrors.evowise.com trusty-security InRelease [65.9 kB]
Get:3 http://ny-mirrors.evowise.com trusty Release.gpg [933 B]
Get:4 http://ny-mirrors.evowise.com trusty Release [58.5 kB]
Get:5 http://ny-mirrors.evowise.com trusty-updates/main Sources [514 kB]
Get:5 http://ny-mirrors.evowise.com trusty-updates/main Sources [514 kB]
Get:6 http://ny-mirrors.evowise.com trusty-updates/restricted Sources [6,449 B]
Get:7 http://ny-mirrors.evowise.com trusty-updates/universe Sources [252 kB]
Get:8 http://ny-mirrors.evowise.com trusty-updates/multiverse Sources [7,230 B]
Get:9 http://ny-mirrors.evowise.com trusty-updates/main amd64 Packages [1,340 kB]
Get:10 http://ny-mirrors.evowise.com trusty-updates/restricted amd64 Packages [21.4 kB]
Get:11 http://ny-mirrors.evowise.com trusty-updates/universe amd64 Packages [585 kB]
Get:12 http://ny-mirrors.evowise.com trusty-updates/multiverse amd64 Packages [16.0 kB]
Get:13 http://ny-mirrors.evowise.com trusty-security/main Sources [198 kB]
Get:13 http://ny-mirrors.evowise.com trusty-security/main Sources [198 kB]
Get:14 http://ny-mirrors.evowise.com trusty-security/restricted Sources [5,050 B]
Get:15 http://ny-mirrors.evowise.com trusty-security/universe Sources [88.4 kB]
Get:16 http://ny-mirrors.evowise.com trusty-security/multiverse Sources [3,013 B]
Get:16 http://ny-mirrors.evowise.com trusty-security/multiverse Sources [3,013 B]
Get:17 http://ny-mirrors.evowise.com trusty-security/main amd64 Packages [914 kB]
Get:18 http://ny-mirrors.evowise.com trusty-security/restricted amd64 Packages [18.1 kB]
Get:19 http://ny-mirrors.evowise.com trusty-security/universe amd64 Packages [289 kB]
Get:20 http://ny-mirrors.evowise.com trusty-security/multiverse amd64 Packages [4,725 B]
Get:21 http://ny-mirrors.evowise.com trusty/main Sources [1,335 kB]
Get:21 http://ny-mirrors.evowise.com trusty/main Sources [1,335 kB]
Get:22 http://ny-mirrors.evowise.com trusty/restricted Sources [5,335 B]
Get:23 http://ny-mirrors.evowise.com trusty/universe Sources [7,926 kB]
Get:24 http://ny-mirrors.evowise.com trusty/multiverse Sources [211 kB]
Get:25 http://ny-mirrors.evowise.com trusty/main amd64 Packages [1,743 kB]
Get:26 http://ny-mirrors.evowise.com trusty/restricted amd64 Packages [16.0 kB]
Get:27 http://ny-mirrors.evowise.com trusty/universe amd64 Packages [7,589 kB]
Get:28 http://ny-mirrors.evowise.com trusty/multiverse amd64 Packages [169 kB]
Fetched 23.4 MB in 1min 28s (266 kB/s)
Reading package lists...
Setting up php5-fpm (5.5.9+dfsg-1ubuntu4.25) ...

Configuration file '/etc/php5/fpm/pool.d/www.conf'
==> Modified (by you or by a script) since installation.
==> Package distributor has shipped an updated version.
What would you like to do about it ? Your options are:
Y or I : install the package maintainer's version
N or O : keep your currently-installed version
D : show the differences between the versions
Z : start a shell to examine the situation
The default action is to keep your current version.
*** www.conf (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing package php5-fpm (--configure):
EOF on stdin at conffile prompt
Errors were encountered while processing:


E: Sub-process /usr/bin/dpkg returned an error code (1)
*** /etc/my_init.d/20_apt_update.sh failed with status 100

*** Killing all processes...

Share this post


Link to post
On 10/11/2017 at 11:52 PM, BobPhoenix said:

 

Anyone manage to fix the container? Mines defunct. :(

 

I tried to drop back to a previous version (pre-v87) but no luck... I'm a bit stumped. This just so happened to be at a time that i moved from CA backup V1 -> v2 :D so nothing to restore.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2018 Lime Technology, Inc.
unRAID® is a registered trademark of Lime Technology, Inc.