linuxserver.io

[Support] Linuxserver.io - Jackett

126 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png

 

Application Name: Jackett

Application Site: https://github.com/Jackett/Jackett

Docker Hub: https://hub.docker.com/r/linuxserver/jackett/

Github: https://github.com/linuxserver/docker-jackett

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, rather use the linuxserver.io forum for support.

  • Upvote 3

Share this post


Link to post

thanks! will try tomorrow!

next wish is a working dropbox docker and my windows vm can shut down

Share this post


Link to post

thanks! will try tomorrow!

next wish is a working dropbox docker and my windows vm can shut down

 

You're welcome, Sparklyballs has worked hard on this.  ;D

 

ken-ji's DropBox version works great, I've put a quick how-to together in the earlier dropbox thread...

Share this post


Link to post

Thanks Sparkly... great job.. One minor bug-ette.... The icon is invisible if running the dark themed web-UI for unRAID...  Not your fault I know.. could we have the black Jackett icon outlined in white? Would be invisible on white themed UI and work fine for black themed UI ??

 

Thanks again.. and keep it up!

Share this post


Link to post

I just want to confirm that it's working fine!

Great work!

 

I used

/config  /mnt/cache/appdata/jackett/

/downloads  /mnt/cache/Downloads/Droptorrents/

 

Where I use the folder Droptorrents in Deluge as a watch folder.

 

I think, in description you should say watch folder not,

/downloads : Point to Downloads location

 

 

Share this post


Link to post

Hi, thanks for this. Is this the latest version and will it auto update when a new version is released?

 

Thanks again

Share this post


Link to post

Hi, thanks for this. Is this the latest version and will it auto update when a new version is released?

 

Thanks again

 

yes, restarting the container will fetch any updates at startup.

 

 

Share this post


Link to post

Hi, thanks for this. Is this the latest version and will it auto update when a new version is released?

 

Thanks again

 

yes, restarting the container will fetch any updates at startup.

 

Thanks

Share this post


Link to post

Hi, thanks for this. Is this the latest version and will it auto update when a new version is released?

 

Thanks again

 

yes, restarting the container will fetch any updates at startup.

 

I can't seem to get it to take the revised icon so maybe it needs change at your end?  Could you borrow sdesbure#s icon which IS visible on a Dark themed unRAID?

 

https://raw.githubusercontent.com/sdesbure/docker-containers/master/images/jackett-icon.png

 

Share this post


Link to post

Sometimes Jackett Docker will just randomly stop responding and I need to restart the docker.

 

This is the last log line before it needs to be restarted:

Error Top level exception System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.Sockets.SocketException: Address already in use

Share this post


Link to post

Ive also had the issue described above for a while now. Just stops responding and I need to restart it, then it works

Share this post


Link to post

None of my searchers were working so I removed and re-added them. Getting this message now:

 

 Configuration failed: Mapping types: WebClientByteResult -> WebClientStringResult Jackett.Utils.Clients.WebClientByteResult -> Jackett.Utils.Clients.WebClientStringResult Destination path: WebClientStringResult Source value: Jackett.Utils.Clients.WebClientByteResult

Share this post


Link to post

None of my searchers were working so I removed and re-added them. Getting this message now:

 

 Configuration failed: Mapping types: WebClientByteResult -> WebClientStringResult Jackett.Utils.Clients.WebClientByteResult -> Jackett.Utils.Clients.WebClientStringResult Destination path: WebClientStringResult Source value: Jackett.Utils.Clients.WebClientByteResult

 

I suspect reading that message is it's a problem with Jackett rather than the container.  Might be worth mentioning on their github page.

Share this post


Link to post

Hi,

 

Do you need to turn off the auto update feature within Jackett?

 

It is on by default, I didn't touch it, but a few days ago my container crashed, looking at the logs it appears this was after it attempted to auto update.

 

On a side note, are there an options in unraid to have dockers restart or update on a schedule? Or do I need to look at cron jobs? The new plugins autoupdate seems to be working a treat, something similar for dockers would be nice.

 

Thanks,

Wob

Share this post


Link to post

Yeah probably a good idea to turn off jackett's autoupdate and use our container autoupdate.  I'm not aware of any way to restart docker containers on a schedule but I guess a script and cron job would work.

Share this post


Link to post

I hit an issue with this docker. The trackers are being place in the appdata dir but the certs needed to read them are in the docker container.

If you update the docker, you'll get errors in the docker logs because it cant decrypt the tracker information because of the mismatch between container and the trackers in appdata.

 

I think the key would be to place the certs in appdata so that the trackers and the keys go together.

 

Is that possible to do?

 

Thanks!

 

Share this post


Link to post

Sometimes Jackett Docker will just randomly stop responding and I need to restart the docker.

 

This is the last log line before it needs to be restarted:

Error Top level exception System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.Sockets.SocketException: Address already in use

 

Just Had this happen to me aswell. After a month of happy use, the app would not respond. I had to restart it to get it up.

I have included the tail of my jackett log.

 

2016-06-21 19:45:37.1285 Error Top level exception System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Net.Sockets.SocketException: Address already in use

  at System.Net.Sockets.Socket.Bind (System.Net.EndPoint local_end) <0x4207ae80 + 0x000ef> in <filename unknown>:0

  at System.Net.EndPointListener..ctor (System.Net.IPAddress addr, Int32 port, Boolean secure) <0x42078380 + 0x00147> in <filename unknown>:0

  at System.Net.EndPointManager.GetEPListener (System.String host, Int32 port, System.Net.HttpListener listener, Boolean secure) <0x42077ee0 + 0x002d3> in <filename unknown>:0

  at System.Net.EndPointManager.AddPrefixInternal (System.String p, System.Net.HttpListener listener) <0x42076290 + 0x000c3> in <filename unknown>:0

  at System.Net.EndPointManager.AddListener (System.Net.HttpListener listener) <0x42075da0 + 0x00147> in <filename unknown>:0

  --- End of inner exception stack trace ---

  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) <0x2acdbb41b960 + 0x000ef> in <filename unknown>:0

  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) <0x2acdbb253ec0 + 0x0002a> in <filename unknown>:0

  at Microsoft.Owin.Hosting.ServerFactory.ServerFactoryAdapter.Create (IAppBuilder builder) <0x42072040 + 0x001f2> in <filename unknown>:0

  at Microsoft.Owin.Hosting.Engine.HostingEngine.StartServer (Microsoft.Owin.Hosting.Engine.StartContext context) <0x42072000 + 0x00029> in <filename unknown>:0

  at Microsoft.Owin.Hosting.Engine.HostingEngine.Start (Microsoft.Owin.Hosting.Engine.StartContext context) <0x42044310 + 0x0015b> in <filename unknown>:0

  at Microsoft.Owin.Hosting.Starter.DirectHostingStarter.Start (Microsoft.Owin.Hosting.StartOptions options) <0x42043660 + 0x0005c> in <filename unknown>:0

  at Microsoft.Owin.Hosting.Starter.HostingStarter.Start (Microsoft.Owin.Hosting.StartOptions options) <0x42042180 + 0x0007b> in <filename unknown>:0

  at Microsoft.Owin.Hosting.WebApp.StartImplementation (IServiceProvider services, Microsoft.Owin.Hosting.StartOptions options) <0x42041b50 + 0x0005e> in <filename unknown>:0

  at Microsoft.Owin.Hosting.WebApp.Start (Microsoft.Owin.Hosting.StartOptions options) <0x42040800 + 0x00027> in <filename unknown>:0

  at Microsoft.Owin.Hosting.WebApp.Start[TStartup] (Microsoft.Owin.Hosting.StartOptions options) <0x42040710 + 0x00047> in <filename unknown>:0

  at Jackett.Services.ServerService.Start () <0x4203fc50 + 0x0020b> in <filename unknown>:0

  at JackettConsole.Program.Main (System.String[] args) <0x41f27d60 + 0x00e16> in <filename unknown>:0

 

I hope this helps in sorting the issue.

 

If you need more info please let me know.

Share this post


Link to post

Image has been rebased to alpine linux, also fixed issue with keypair data not being persistent, first update to new baseimage will still require keypair data to be reentered, but from then on it should be persistent.

 

For more information on the changes from linuxserver.io, see.

 

http://lime-technology.com/forum/index.php?topic=50793

Share this post


Link to post

I updated my container yesterday, everything was running fine, but now when I log into it I get an error "Error loading Jackett settings, request to Jackett server failed" and all my config is gone, if I click on anything I just get errors ending in request to jack failed.

 

Docker log shows it boots up fine, I did restart to see if that would help but no luck. No further errors are show.

 

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We do accept donations at:
https://www.linuxserver.io/donations
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-update: executing...
[cont-init.d] 20-update: exited 0.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
08-10 17:15:10 Info Starting Jackett 0.7.303.0
08-10 17:15:10 Info Using HTTP Client: UnixLibCurlWebClient
08-10 17:15:10 Info LibCurl init Ok
08-10 17:15:10 Info LibCurl version libcurl/7.50.1 OpenSSL/1.0.2h zlib/1.2.8 libssh2/1.7.0

08-10 17:15:10 Info Starting web server at http://*:9117/
08-10 17:15:45 Info redirecting to /jackett/Admin/Dashboard

Share this post


Link to post

Looking at my logs since my last post and it appears that jacket is still working from a search point of view, I am still seeing logs for results found. But I can't access the admin dashboard.

Share this post


Link to post

Looking at my logs since my last post and it appears that jacket is still working from a search point of view, I am still seeing logs for results found. But I can't access the admin dashboard.

 

Tried clearing your browser cache?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2018 Lime Technology, Inc.
unRAID® is a registered trademark of Lime Technology, Inc.