linuxserver.io

[Support] Linuxserver.io - Jackett

126 posts in this topic Last Reply

Recommended Posts

19 minutes ago, BillClinton said:

Black hole is a fallback way of adding a torrent file to a deluge. It’s where you put .torrent files if you grab one manually. The downloader will see it and start the download. It’s also a way of getting apps like Sonarr to talk to downloaders that can’t handle the api calls etc.

 

 

Sent from my iPad using Tapatalk

 

So the path should be /mnt/disks/deluge/watch for the "watch" folder used by deluge? Never used that feature but thought it was for creating an upload torrent.

Share this post


Link to post
So the path should be /mnt/disks/deluge/watch for the "watch" folder used by deluge? Never used that feature but thought it was for creating an upload torrent.



Yes that’s correct. You’ll need to specify the folder in deluge preferences.


Sent from my iPad using Tapatalk
  • Upvote 1

Share this post


Link to post
7 minutes ago, BillClinton said:

 

 


Yes that’s correct. You’ll need to specify the folder in deluge preferences.


Sent from my iPad using Tapatalk

 

 

Thanks

Share this post


Link to post

My indexers that need my privoxy proxy are no longer working.  I've checked the proxy with a browser and it's working, but the indexers are failing tests.  Has something changed?

 

Thanks

 

5a004454dc220_FireShotCapture2-Highlander_UpdateContainer_-http___172_30_12.2_Dashboard_UpdateContainer.thumb.png.2f757e9fc8add361149eacb47c691424.png

 

Share this post


Link to post

@DZMM came across the same(?) issue in the last couple of days, found the reason:

 

Here is the issue, looks like it was an issue Jackett introduced at some point.

https://github.com/SickRage/SickRage/issues/4132

 

Quote

...definitely looks like sickrage is trying to parse the filename from the URL instead of the Content-Disposition header.

This change was introduced to jackett because support for magnet links were added.
In case a tracker doesn't provide normal torrent files and they're only available from the torrent's details page a request to the jackett download link will return a redirect (HTTP status code 301, Moved Permanently) with the Location header set to a magnet URI.
Not sure if sickrage can handle this case. This is used by e.g. the jackett ETTV and Torrent Downloads indexers.

 

 

Other users noted a temporary solution:

Quote

Downgraded to Jackett v0.8.355 and disabled autoupdate in Jackett GUI and it works like normal now.

 

Edited by tjb_altf4

Share this post


Link to post

So the whole specifying a version is new to me, but here's how to do it for the uninitiated.

Based on github thread, I'm dropping back to tag 83 (from: https://hub.docker.com/r/linuxserver/jackett/tags/)


In the edit screen of the Jackett docker, turn on the advanced view (top right).

In the repository field add a colon + tag number so it looks like: linuxserver/jackett:83

 

This fixed the issues I was having.

 

 

 

 

 

 

Edited by tjb_altf4

Share this post


Link to post
1 hour ago, tjb_altf4 said:

add a semicolon + tag number so it looks like: linuxserver/jackett:83

Did you mean colon + tag?

Or maybe it should be linuxserver/jacket;83

Share this post


Link to post

My installation is working now without changing the version, so I think the docker must have updated (although my docker is now behind a VPN rather than using privoxy)

Share this post


Link to post

Yeah I had restarted my server over the weekend and it must of updated to latest on startup.

47 minutes ago, wgstarks said:

Did you mean colon + tag?

Or maybe it should be linuxserver/jacket;83

Yeah I had restarted my server over the weekend and it must of updated to latest on startup.

yes colon :)

Share this post


Link to post
On 11/14/2017 at 4:42 AM, tjb_altf4 said:

 

Based on github thread, I'm dropping back to tag 83 (from: https://hub.docker.com/r/linuxserver/jackett/tags/)

 

This fixed the issues I was having.

 

 

 

 

 

 

 

Worked for me also up until today and tried all other tags per the same guidance with no results.  Is there any more on this or is it fixed and I'm the lone user with issues on my end? 

Share this post


Link to post

Reverted to latest build this afternoon, issues mentioned in my previous post have been resolved.

Looking at github, the issue was resolved a few weeks ago :) 

Share this post


Link to post

@tjb_altf4 I kept my Jackett to the latest version and just realized that the proxy settings were broken.  The only time I get this to work again was to follow your instruction 

 

Since the official unRaid 6.4.0, I gave my binhex-delugevpn an IP on a different subnet, and the vpn and privoxy seem to work; however, my Jackett proxy settings broke again after pointing it to use the new IP of the proxy. It used to be pointing to unRaid's IP when it was working. 

 

Would it be possible to point Jackett to use delugevpn as a proxy if they are on two different subnet?

I am trying to re-ip my containers because I don't want my users to keep going to my unRaid server's IP. So far the only thing I got it working after re-IP-ing are Emby, Booksonic, Unifi

Share this post


Link to post
Posted (edited)

Since last night's update, this Docker isn't working. It start up and the web UI works, but searching and testing the indexers doesn't.

I get these errors in the log:

 

https://pastebin.com/MKCteBdY

Edited by ICDeadPpl

Share this post


Link to post
7 minutes ago, sparklyballs said:

@ICDeadPpl i'd suggest opening an issue here https://github.com/Jackett/Jackett

 

and please for the sake of everyone's scrolling fingers use pastebin or similar service for a log of that size

 

 

Sorry about that, fixed that. Must've been too early for me. -_-

Share this post


Link to post

How can I access the Definitions folder in this docker? I'm trying to add a couple custom yml files and my log says it's accessing

/app/Jackett/Definitions/

for all the pre-installed sites, but that folder doesn't exist inside my appconfig folder. Am I missing something?

Share this post


Link to post
Posted (edited)
20 minutes ago, druck21 said:

How can I access the Definitions folder in this docker? I'm trying to add a couple custom yml files and my log says it's accessing


/app/Jackett/Definitions/

for all the pre-installed sites, but that folder doesn't exist inside my appconfig folder. Am I missing something?

 

If the folder isn't in the appconfig folder, then it's in the docker image. You'll have to copy it over. The best way to do that is to put it in the appconfig folder, open a command line in docker, and copy it to the right place. I don't remember the command off the top of my head but it's something like `docker exec -i -t <name> bash`. That might even be right...

Anyway, the problem is that it gets wiped out anytime the image get updated. Really, unless it can go in one of the mapped folders, it won't survive changes to the image. You could try changing the docker settings to add a map to that folder to another folder on your system (the cache drive or wherever you keep your appconfig folders for example) and put the file in there. But be careful. with doing that. You don't want to break things 

Edited by bobbintb

Share this post


Link to post

it is possible to update jackett to the new pre-release  0.8.862 which fixes some torrents sites?

Share this post


Link to post
2 minutes ago, HarryRosen said:

it is possible to update jackett to the new pre-release  0.8.862 which fixes some torrents sites?

 

It'll get rebuilt when the Jackett team push a new release. 

Share this post


Link to post

sorry to be a pain, but possible to update to v0.8.870 the docker doesn't seem to be updating

Share this post


Link to post

Hi,

I un-ticked the 'allow external access' box, and now I can't access the webpage anymore.  I assumed external was referring to 'from the internet' and not localhost.  Anyway to get back in, or am I gonna have to setup my docker from scratch?

 

Thanks for any help.

Share this post


Link to post
Hi,
I un-ticked the 'allow external access' box, and now I can't access the webpage anymore.  I assumed external was referring to 'from the internet' and not localhost.  Anyway to get back in, or am I gonna have to setup my docker from scratch?
 
Thanks for any help.
You can take a look in the appdata folder and see if there's a config file you can edit manually, otherwise you're SOOL

Share this post


Link to post
On 5/21/2018 at 10:03 AM, DingHo said:

Hi,

I un-ticked the 'allow external access' box, and now I can't access the webpage anymore.  I assumed external was referring to 'from the internet' and not localhost.  Anyway to get back in, or am I gonna have to setup my docker from scratch?

 

Thanks for any help.

 

3rd person to do that!, not saying who the first person was 🤩 solution:-

 

https://lime-technology.com/forums/topic/61433-support-binhex-jackett/?do=findComment&comment=653579

 

Share this post


Link to post

REQ: New icon that works in both LIGHT and DARK themes ;-)

Share this post


Link to post
REQ: New icon that works in both LIGHT and DARK themes wink.png
Feel free to find one and submit it.....

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2018 Lime Technology, Inc.
unRAID® is a registered trademark of Lime Technology, Inc.