linuxserver.io

[Support] Linuxserver.io - Rutorrent

467 posts in this topic Last Reply

Recommended Posts

1 hour ago, DZMM said:

Thanks - that was driving me crazy

 

 

This is odd, when I restart my docker, the upload limit is 4.7 Mb/s and download is 9.7 Mb/s.

I havent changed my rtorrent.rc file which still states 

download_rate = 10000
upload_rate = 5000

 

Share this post


Link to post
38 minutes ago, poldim said:

 

 

This is odd, when I restart my docker, the upload limit is 4.7 Mb/s and download is 9.7 Mb/s.

I havent changed my rtorrent.rc file which still states 


download_rate = 10000
upload_rate = 5000

 

Why is that odd?

Share this post


Link to post

Is it possible, using 

docker exec -it rutorrent bash

to connect to the rtorrent screen via the terminal?

 

Running screen -ls I can see the detached session for rtorrent but when I try to attach to it I receive the error

 

Must be connected to a terminal.


Thanks

Share this post


Link to post

what is the username and pass word for this docker

Share this post


Link to post

admin
rutorrent
It's on the docker page/link


Sent from my SM-N900W8 using Tapatalk

Share this post


Link to post

If I make changes in the /appdata/rutorrent/rtorrent/rtorrent.rc file will it persist after I upgrade the docker?  It looks like it will but I am not 100% sure - I changed the download rate to 0.  After an upgrade it shows in the settings through the web UI as 102400 KiB/s - is that what the web UI shows when you set to 0 which is supposed to be unlimited?

Share this post


Link to post
[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

After installing and changing port 80 to 8099. I cant access the webui. This is all I have in logs. How do I fix this?

Share this post


Link to post

Hello all,

 

Today I finally purchased and installed unraid and trying to get my server up and running. I have installed this docker and having some problem. I believe is something with the permissions but I´m not sure. I have problem saving my config. I tried do change my download location, port, max seed etc (all within web gui) after a reboot of the docker all my configuration is gone, back to default. I have this problem with several dockers, tried other rTorrent and ruTorrent docker. (qBittorrent docker refuses to even start the web gui.) Only torrent client that I got to work is deluge(able to save settings).

 

 

any suggestions? thanks!

Share this post


Link to post
10 minutes ago, zarnexx said:

Hello all,

 

Today I finally purchased and installed unraid and trying to get my server up and running. I have installed this docker and having some problem. I believe is something with the permissions but I´m not sure. I have problem saving my config. I tried do change my download location, port, max seed etc (all within web gui) after a reboot of the docker all my configuration is gone, back to default. I have this problem with several dockers, tried other rTorrent and ruTorrent docker. (qBittorrent docker refuses to even start the web gui.) Only torrent client that I got to work is deluge(able to save settings).

 

 

any suggestions? thanks!

 

Share this post


Link to post
3 minutes ago, trurl said:

 

Thanks for this ^^

 

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="rutorrent" --net="bridge" -e TZ="Europe/Berlin" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 8116:80/tcp -p 51413:51413/tcp -p 6881:6881/udp -v "/mnt/disks/WDC_WD3001FFSX_68JNUN0_WD_WMC5D0D9L6CW/rutorrent/":"/downloads":rw -v "/mnt/user/appdata/rutorrent":"/config":rw linuxserver/rutorrent

e4968906d9296250c5c92a7841ef6a730023d8c3193fb1408b8ee21c51357b54

 

Quote

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donations/
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
'access-swap.sh' -> '/config/rutorrent/settings/access-swap.sh'
'access.ini' -> '/config/rutorrent/settings/access.ini'
'access_no' -> '/config/rutorrent/settings/access_no'
'access_yes' -> '/config/rutorrent/settings/access_yes'
'config.php' -> '/config/rutorrent/settings/config.php'
'plugins.ini' -> '/config/rutorrent/settings/plugins.ini'
[cont-init.d] 20-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] syncing disks.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.
[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...
usermod: no changes

-------------------------------------
_ _ _
| |___| (_) ___
| / __| | |/ _ \
| \__ \ | | (_) |
|_|___/ |_|\___/
|_|

Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donations/
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
[cont-init.d] 20-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

The logs above is from right after a configuration change and reboot.

 

Share this post


Link to post

hey guys i need some help, i keep getting this error.

Capture.PNG.dcf63800c44be76f220d89b6dd94e210.PNG

Here goes the log

Capture1.PNG.042270627c8399b48d8ea72fb01f9ee8.PNG

If i restart the docker it will work some seconds and then it just stops working and start showing error.Capture4.PNG.be47ff01d19970b6a591bb4d409f7603.PNG

 

Share this post


Link to post
5 hours ago, Max said:

hey guys i need some help,

 

Share this post


Link to post
59 minutes ago, trurl said:

 

here goes the log.

 


Brought to you by linuxserver.io
We gratefully accept donations at:
https://www.linuxserver.io/donations/
-------------------------------------
GID/UID
-------------------------------------
User uid: 99
User gid: 100
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
'access-swap.sh' -> '/config/rutorrent/settings/access-swap.sh'
'access.ini' -> '/config/rutorrent/settings/access.ini'
'access_no' -> '/config/rutorrent/settings/access_no'
'access_yes' -> '/config/rutorrent/settings/access_yes'
'config.php' -> '/config/rutorrent/settings/config.php'
'plugins.ini' -> '/config/rutorrent/settings/plugins.ini'
[cont-init.d] 20-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
==> /config/log/rtorrent/rtorrent.log <==
tail: cannot open '268' for reading: No such file or directory

-

And Here Goes the Docker run command.

 

 

 

 

Pulling image: linuxserver/rutorrent:latest

IMAGE ID [latest]: Pulling from linuxserver/rutorrent. 
Status: Image is up to date for linuxserver/rutorrent:latest

TOTAL DATA PULLED: 0 B

 

 

Stopping container: rutorrent

Successfully stopped container 'rutorrent'

 

 

Removing container: rutorrent

Successfully removed container 'rutorrent'

 

 

Command:root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="rutorrent" --net="bridge" -e TZ="Asia/Calcutta" -e HOST_OS="unRAID" -e "PUID"="99" -e "PGID"="100" -p 84:80/tcp -p 51413:51413/tcp -p 6881:6881/udp -v "/mnt/user/Window share/rutorrent/":"/downloads":rw -v "/mnt/user/appdata/rutorrent":"/config":rw linuxserver/rutorrent

f7d1d7c9fb033c1edb8431116f72622d67e714034f53a445c461f80d9cd95c7b

The command finished successfully!

Edited by Max

Share this post


Link to post

@trurl Hey guys could it be all because of some corrupted torrent file cause i noticed that after restarting docker every time, it would start the rechecking process and at somewhere around 20-25 % that error poops in for every single time. So what i did was deleted some of files it was checking when it was around that 20-25 % mark and voila no more error and now its like 4-5 hours since its running perfectly.

So could it be all because of some file that got corrupted somehow.

Share this post


Link to post

Hi there,

I have two questions on this docker. 

 

1. Is there a way to put authentication on the webgui?

2. Can I set a listening port without exposing the webgui publicly? I'm running pfsense with the docker running in port 8885. I have the port forward set from the listening port to redirect to port 8885, but now the webgui is wide-open. I just want to have the listening port open without compromising security.

 

Thanks,

Share this post


Link to post

After the last update, I can not add a torrent  via webui addon, what happened? :/

Edited by memphisto

Share this post


Link to post
40 minutes ago, memphisto said:

After the last update, I can not add a torrent  via webui addon, what happened? :/

 

 

dunno , just added ubuntu iso torrent via url and downloaded torrent file with no problem and they're downloading.

 

 

Share this post


Link to post
40 minutes ago, memphisto said:

I got Internal server error (500) ¬¬

 

 

well that would suggest a server side error , ie the torrent site.

Share this post


Link to post

When I open the webui rutorrent interface directly in IE11 a got

[27.05.2017 14:23:12] JS error: [http://192.168.1.100:9009/js/content.js : 72] Access Denied.
And torrent is not added to downloading. Before update works fine directly webui and FF53 addon too.
Edited by memphisto

Share this post


Link to post
11 minutes ago, memphisto said:

When I open the webui rutorrent interface directly in IE11 a got

[27.05.2017 14:23:12] JS error: [http://192.168.1.100:9009/js/content.js : 72] Access Denied.
And torrent is not added to downloading. Before update works fine directly webui and FF53 addon too.

 

/js/content.js is not the webui

it's at whatever port you mapped 80 to , eg if you mapped 80 to 8088 then it's <your-ip>:8088

Share this post


Link to post
17 hours ago, memphisto said:

After the last update, I can not add a torrent  via webui addon, what happened? :/

 

Same with me, i cant manually add torrents anymore, also couchpotato and sonar cant add torrents either.... seems to be after the last update, I haven't changed anything else

Share this post


Link to post
6 minutes ago, memphisto said:

After today's update, it was fixed. :-)

 

 

yeah nginx in the newer alpine uses two locations for tmp files for some reason and the perms weren't set on the other one

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2018 Lime Technology, Inc.
unRAID® is a registered trademark of Lime Technology, Inc.