meerkat154

Moving from Old to New Unraid

4 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Decommissioning my current Unraid server which is stacked using 12 x 3TB drives to a newer Ryzen setup with 6 x 8TB drives.

Any suggestions on steps for this move?

 

  1. Create a 30 day trial USB with Unraid 6.5.2.
  2. Backup old Unraid USB drive and specifically the registration file.
  3. Build the new Ryzen 8TB Unraid with Ryzen patches and duplicate all the shares (names) and filesystems on the new array.
  4. Format new 8TB drives on new Ryzen setup and build new parity.
  5. Copy all the data from old Unraid to new Unraid (Same destination shares)
  6. Erase old Unraid USB drive, load a new clean copy of Unraid 6.5.2 and restore KEY file registered to the old USB thumb drive.
  7. Copy the config directory from the new Unraid USB drive to the new USB Unraid drive.
  8. Boot Old USB thumb drive with registered key which has new config directory for the new Unraid setup.

 

Hope that makes sense...wondering if I am missing something.

I'm at step 5 right now,

Thanks,

Kat

 

Edited by meerkat154
Drives Sizes

Share this post


Link to post

What version of unRAID is the old server?

 

Your plan sounds good, but you don't mention cache or any configurations you might want to keep from the old server such as docker templates.

Share this post


Link to post

Both new and old Unraid are on latest 6.5.2. I do have a M.2 Cache drive but not enabled yet in the new build.

 

When I had the M.2 enabled as cache I was receiving warning messages from the motherboard the M.2 drive was getting too hot. This is because the entire new Unraid is sitting outside a case and not ventilated/cooled correctly. Once I'm done copying all the data from old to new and installed the new Unraid in a case I will enable the cache drive.

 

I had to start over with the new raid because I had forgotten to enable XFS-Encryption on the drives. No rush...I will move everything at ease.

 

 

Share this post


Link to post
1 hour ago, meerkat154 said:

the M.2 drive was getting too hot.

 

I think many have had this. I had this problem on my desktop and took me a while to figure out why it was crashing. The final straw was when it began rebooting then not finding the M.2 boot drive. I put a heat sink on it and it seems OK now.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2018 Lime Technology, Inc.
unRAID® is a registered trademark of Lime Technology, Inc.