efthernet

Help flashing LSI 9206-16

6 posts in this topic Last Reply

Recommended Posts

 I'm having an issues were sas2flash commands are not being recognized on bios shell. I install freedos using rufus to a couple usb drives but they all got the same message. I reset my mb bios setting to factory and can see the bios load for card with following error I can access the cards utility but any change i make freezes utility not letting save anything so Im not sure if it has the correct firmware. I'm using the following firmware attached seems to be latest, when I boot onto unraid the card loads and can see drives but drops off after 5 minutes giving the following error:

Aug  5 14:29:18 VRAID kernel: mpt2sas_cm1: SAS host is non-operational !!!!
...
Aug  5 14:29:24 VRAID kernel: mpt2sas_cm0: sending diag reset !!
Aug  5 14:29:25 VRAID kernel: mpt2sas_cm0: diag reset: FAILED

 

sasbios_rel/mptsas2.rom

Firmware/HBA_9206_16e_IT/9206.bin

sas2flsh_dos_rel/sas2flsh.exe

Also added efi/boot/bootx64

 

sas2flsh -o -e 6

sas2flsh -o -f 9206it.bin -b mptsas2.rom

 

 

image.thumb.png.d9bf567d1127b5b081c2f3cc03e0e902.png

 

image.thumb.png.99b5ab6a408750e7c28cfcf89e1be311.png

 

 

Thanks in advance!

 

9206-16e_Package_P20_IT_FW_BIOS_for_MSDOS_Windows.zip

Share this post


Link to post

You are missing you have a "SAS Address NOT programmed on controller..." . Have you got it noted somewhere?

 

Share this post


Link to post
Posted (edited)
19 hours ago, ghiglie said:

You are missing you have a "SAS Address NOT programmed on controller..." . Have you got it noted somewhere?

 

 

No I don't, is there a way to recover it or reset it so I can start from scratch. I saw this online not sure if it would apply in my case? Also, I did I use the correct firmware and bios? 

 

https://forums.freenas.org/index.php?threads/ibm-serveraid-m1015-and-no-lsi-sas-adapters-found.27445/

 

Edited by efthernet

Share this post


Link to post
Posted (edited)

There should be a sticker on the card, with a "500605B". Anyway, with some Google-fu:

sas2flash -o -sasaddr 500605BXXXXXXXXXX 

randomize the Xs

Edited by ghiglie

Share this post


Link to post
15 hours ago, ghiglie said:

There should be a sticker on the card, with a "500605B". Anyway, with some Google-fu:


sas2flash -o -sasaddr 500605BXXXXXXXXXX 

randomize the Xs

 

I keep getting the error 'sas2flash' is not redognized as an inter/external comand, operable program ... I used rufus to install DOS on a usb the added the sas2flash from the firmware from but I guess Im missing something? I need to improve my google-fu skills ... 

9206-16e_Package_P20_IT_FW_BIOS_for_MSDOS_Windows.zip

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2018 Lime Technology, Inc.
unRAID® is a registered trademark of Lime Technology, Inc.