tucansam

Oh boy, here we go, CRC errors

3 posts in this topic Last Reply

Recommended Posts

This is my backup server, it comes on once a week to do a copy of changed files from my primary.  Has run 100% for years.  Hasn't moved (I say that because it might be a loose controller card) but tonight's copy gave me zillions of CRC errors across every disk in the array.

 

Your advice is most welcome.

nad.jpg

ffs1-diagnostics-20180810-0449.zip

Share this post


Link to post

If it happens to one disk it's usually a bad cable. When it happens to eight disks simultaneously I'd suspect that "loose controller card". If it proves not to be that the next thing I'd suspect is the power supply or the power distribution to the disks.

Share this post


Link to post

I was getting these errors for the first time ever, but nowhere near as bad as yours. Mine was spitting out 1 or 2 a week, and only on certain drives. In my case, it ended up being a defective SFF-8087 to breakout 4xSATA cable that I had. Replaced it and it's been three months, not a single one since.

 

Given that you have 8 drives that are spitting out errors, I truly hope that it isn't an HBA card that has gone bad. If you have a spare HBA or data cables, I'd swap and see if that alleviates the issue.

 

Thankfully those errors *shouldn't* cause any data corruption issues, from what I've seen (checksums for random files on my drives came back fine,) however, I've had a total of 14 errors on the 4 drives on the cable, which you've obviously had a lot more of.


Good luck.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Copyright © 2005-2018 Lime Technology, Inc.
unRAID® is a registered trademark of Lime Technology, Inc.